Delays in processing persons
Incident Report for Emptor
Resolved
This issue has been resolved.
Posted Jan 12, 2023 - 06:54 UTC
Monitoring
We have resolved the issue causing delayed processing and are seeing persons complete now across all affected countries. We are monitoring for full resolution.
Posted Jan 12, 2023 - 06:25 UTC
Identified
We have identified the issue and are developing a mitigation.
Posted Jan 12, 2023 - 05:35 UTC
Investigating
We are seeing increased processing time for persons in multiple countries and are investigating.
Posted Jan 12, 2023 - 04:35 UTC
This incident affected: Colombia (Justice Record, Police Record), Chile (Justice Certificate), and Peru (Justice Certificate).