Delays processing persons in Costa Rica
Incident Report for Emptor
Resolved
We think the impact from the issue is over.
Posted Feb 15, 2023 - 17:41 UTC
Monitoring
Persons in process are completing now.
Posted Feb 15, 2023 - 16:51 UTC
Identified
We have identified the issue and are taking steps to mitigate it.
Posted Feb 15, 2023 - 15:59 UTC
Investigating
We are investigating increased processing times for persons in Costa Rica.
Posted Feb 15, 2023 - 15:39 UTC
This incident affected: Costa Rica (BGC Costa Rica).