Peru labor certificate source downtime
Incident Report for Emptor
Resolved
This incident has been resolved.
Posted Jun 22, 2021 - 13:06 UTC
Monitoring
We are seeing processing delays for persons in Peru with the labor certificate check enabled due to downtime at the source.
Posted Jun 21, 2021 - 14:05 UTC
This incident affected: Peru (Labor Certificate).