Costa Rica BGCs delayed
Incident Report for Emptor
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 19:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2021 - 18:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 14, 2021 - 15:34 UTC
Investigating
We are currently investigating this issue.
Posted Apr 14, 2021 - 14:33 UTC
This incident affected: Costa Rica (BGC Costa Rica).