Ecuador processing delays due to source downtime
Incident Report for Emptor
Resolved
This incident has been resolved.
Posted Aug 09, 2021 - 19:01 UTC
Monitoring
We are seeing increased processing times for some EC persons due to source instability and downtime.
Posted Jun 23, 2021 - 15:03 UTC
This incident affected: Ecuador (License Status, Driving Record).