Colombia police records source downtime delaying completion of reports
Incident Report for Emptor
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 18:05 UTC
Investigating
We are currently investigating this issue.
Posted Jan 13, 2021 - 17:37 UTC
This incident affected: Colombia (Police Record).