Mexico Federal Criminal Justice Center sentences cannot be reviewed due to source downtime
Incident Report for Emptor
Resolved
This incident has been resolved.
Posted Feb 08, 2023 - 04:22 UTC
Identified
A source required to validate results for certain persons matched is suffering from downtime, results which require this source will be delayed.
Posted Feb 03, 2023 - 14:56 UTC
This incident affected: Mexico (BGC Mexico).